Ultimak Rail Report and Pics - Page 2 - Shooting Sports Forum


Ruger Mini-14 and Mini-30 Ruger Mini-14 and Mini-30 family of rifles

Like Tree1Likes
Reply
 
LinkBack Thread Tools Display Modes
Old 12-10-2011, 10:39   #26
Full Member
 
Talshiar's Avatar
 
Join Date: Oct 2008
Posts: 47
Originally Posted by Crowcifier666 View Post
Anyone looking to sell their Ultimak? I've got a Burris scout dying to go on my 580 tactical.

I'm thinking of taking mine because I never use it, it looks brand new. If you're interested let me know.
__________________
"The strongest reason for people to retain the right to keep and bear arms is, as a last resort, to protect themselves against tyranny in government."

-Thomas Jefferson
Talshiar is offline   Reply With Quote
Old 12-12-2011, 03:26   #27
Full Member
 
Talshiar's Avatar
 
Join Date: Oct 2008
Posts: 47
It is off, it still looks brand new. If anyone needs one let me know.
__________________
"The strongest reason for people to retain the right to keep and bear arms is, as a last resort, to protect themselves against tyranny in government."

-Thomas Jefferson
Talshiar is offline   Reply With Quote
Old 12-19-2011, 11:03   #28
Registered Member
 
Join Date: Dec 2011
Posts: 3
Do you still have the ultimak available? Does it fit the pencil barrels or the later models?
NoNel is offline   Reply With Quote
 
Old 12-19-2011, 11:16   #29
Registered Member
 
Join Date: Dec 2011
Posts: 3
Sorry, you already answered me by pm. Just figured it out. Thanks.
NoNel is offline   Reply With Quote
Old 07-23-2020, 13:00   #30
Full Member
 
Join Date: Aug 2017
Posts: 15
Anyone else have problems with the rear barrel clamp of an Ultimak rail rubbing the operating rod about 50% of the time? I installed an ASI adjustable gas block and now the rod is rubbing the clamp. I look at the rear of the Ultimak and it seems to be level with the receiver and I can't really tell if I canted the gas block on the barrel to impart a twist in the rail towards the front. The gas block installs evenly with maybe a matchbook thick gap if that and the rail has a similarly even gap on both sides to the wood stock, so I'm at a loss unless Ultimak assumed a larger gap at the gas block (factory vs. ASI) or if my operating rod was cast slightly wider than usual, or I mucked something less obvious up. Any ideas? Worst case scenario I guess I'll sand/file down the edge of the aluminum clamp until the rod clears it 100% of the time. My fear is that it could lead to an out of battery bolt or a failure to extract from the friction.
Waher is offline   Reply With Quote
Old 07-25-2020, 02:00   #31
Temp Banned!
 
Join Date: Mar 2011
Location: Natagua
Posts: 6,258
Originally Posted by Carbine85 View Post
183 Stainless
Are you sure you have the right one for yours? There is a different model for the 580+ series that would not fit correctly on a 183
sandog likes this.
40nascar is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 11:08.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
All information is copyright by Perfectunion.com unless already under copyright.