Perfect Union banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi,

So I recently bought my father a used mini 14 in good condition. Looks to have very little wear, it was a little dirty when I cleaned before we went to the range. It is a mini 14 ranch black stock stainless barrel model. It came with a 10rd "promag" so I got another 20 round authentic ruger mag. My prolem is with both mags after you shoot the first found ths bolt locks back and has to be pushed forward to chamber the next round? The first few mag needed this done 3 to 4 times even on ths 10 round. After about 90 rounds it got to the point it only holds open after the first round. After you force the 2nd rd to chamber it seems to work. All brand new 55 and 62gr brass cased. Any ideas? Thought I was gettin him a nice reliable gun

Any help would be GREATLY appreciated

Thanks
James
 

·
Registered
Joined
·
3,377 Posts
The bolt locks back? Or it is stopped from going forward by something like the bolt is not stripping a round from the magazine? I would try loading fewer rounds in the magazine so the spring is not compressed too tight. If it works ok then I suspect the main spring has lost it's tension and is not stripping the rounds from the magazine or something needs lubed and everything is dragging. What is the series number on the side of the receiver?

One more possiblilty, did you take the channel out of the stock when you cleaned it? If you get it back in wrong the rear of the channel catches the op rod. Does the black stock have the stiffener that is screwed in with a screw on each side of the stock? If you do it is not a factory stock. We need to know the series of Mini you have. kwg
 

·
Registered
Joined
·
494 Posts
Did you put the recoil spring guide in upside down? That will make the rifle hard to cycle.

Maybe the video will help:

Pay attention to the orientation of the wedge shaped end of the guide rod.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
The bolt locks back? Or it is stopped from going forward by something like the bolt is not stripping a round from the magazine? I would try loading fewer rounds in the magazine so the spring is not compressed too tight. If it works ok then I suspect the main spring has lost it's tension and is not stripping the rounds from the magazine or something needs lubed and everything is dragging. What is the series number on the side of the receiver?

One more possiblilty, did you take the channel out of the stock when you cleaned it? If you get it back in wrong the rear of the channel catches the op rod. Does the black stock have the stiffener that is screwed in with a screw on each side of the stock? If you do it is not a factory stock. We need to know the series of Mini you have. kwg
Thank you very much for the quick response. I will have to get the model number after work. It seemed to have a harder time feeding the next round with the 10 round pro mag so I took it home and cleaned it. Lubed EVERYTHING very very well took it out back with the factory 20 rd mag and just put 6 lake city 62gr ammo. Same thing first round shot. Bolt stayed back, I pushed it forward to chamber the next round and the last 5 shot flawlessly. I did notice when cleaning I could pull the bolt back if I gentlely let go it would hang up . You could pretty much breathe on it to make it slide foward but didnt seem right. Other then that gun shoots great very happy with it
 

·
Registered
Joined
·
10,469 Posts
Sounds like liner is not snapped all the way down and dragging against the op-rod when it's fired and recoils back.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Thanks for the help guys, couldnt figure it out so its getting shipped back to ruger...I went through 4 twenty rd ruger mags..same thing every time first round chambers...second hangs up and I push the charging handle forward and the other 18 shoot out no problem
 

·
Registered
Joined
·
3,377 Posts
If you took it apart once you can do it twice. You just need to make sure you get it back together correctly. If it still malfuncxtions then send it back. We still don't know the series number which we need to help you with the problem. kwg
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Im not worried about taking it apart and getting it back together that was pretty straightforward, I did it twice by the book to make sure I didnt put something in wrong. The series is 5817 mini 14/20. Ranch serial number is 58X-0081X. Either way after both cleanings same issue. Hopefully ruger sorts it out. Thanks again
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top