Perfect Union banner
1 - 5 of 5 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter · #1 ·
Intermittent issue where after I shoot around 50 rounds the bolt lock won't release consistently after loading a new mag and trying to chamber the first new round. Pull the bolt back but the plunger pin stays locked. Finally I push down mag follower, slide unlocks and cartridge loads and everything else works fine. I had polished up the plunger as I though the problem was it was binding in the hole but I'm starting to think my diagnosis might be wrong. Have shot around 400 rounds through it. No other issues like FTF or FTE. Suggestions of other areas where it may be binding?
 

·
Registered
Joined
·
2,269 Posts
Sounds like a bad ejector/bolt stop or there could be some dirt on unburnt powder residue under it. Does it release every time without a magazine in place? It could also be an out of spec magazine.
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #3 ·
Found the issue and a easy fix...

Had the same issue with the pin binding and not releasing on my last range trip. Finally got around to tearing it down to investigate. It wasn't dirt. I have a spare pin and both the old and new would bind. Neither would spin in the hole and both would bind when reinstalling. Took a 5/32 drill bit in a tap handle and used it like a reamer. Apparently had a piece of casting in the hole causing the binding as after I reamed it it works perfectly. I will do a range check this weekend but looks like it was a simple fix.
 
1 - 5 of 5 Posts
Top